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1. Introduction

The pure::variants Connector for EMF Feature Mapping enables pure::variants to flexibly create multiple differing
variants from a single EMF master model. This provides a boost in development efficiency since instead of having
to merge changes in slight variations of the base project, the change is applied once to the master project and then
all relevant variants are automatically generated by pure::variants.

The Connector supports EMF-based models. It is tool independent and can be used with any standard compliant
EMF tool chain. To simplify management of variability information in EMF it contains an optional standalone
user interface for handling variability information in ecore files.

1.1. Software Requirements

The pure::variants Connector for EMF Feature Mapping is an extension for pure::variants and is available on all
supported platforms.

In order to use the user interface integration the installation of the EMF and GMF framework is required:

EMF: EMF - Eclipse Modeling Framework SDK since Version 2.5.0. See http://www.eclipse.org/model-
ing/emf/.

GMF: GMF - Graphical Modeling Framework since Version 1.2.1. See http://www.eclipse.org/modeling/gmp/.

1.2. Installation

Please consult section "Additional pure::variants Plug-ins" in the pure::variants User's Guide for detailed infor-
mation on how to install the connector (menu Help -> Help Contents and then pure::variants User's Guide -
> Additional pure::variants Extensions).

http://www.eclipse.org/modeling/emf/
http://www.eclipse.org/modeling/emf/
http://www.eclipse.org/modeling/gmp/
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1.3. About this Manual

The reader is expected to have basic knowledge about and experiences with pure::variants. The pure::variants
manual is available in online help as well as in printable PDF format.

2. Using the pure::variants Connector for EMF Feature Map-
ping

2.1. Starting pure::variants

Depending on the installation method used either start the pure::variants-enabled Eclipse or under Windows select
the pure::variants item from the program menu.

If the Variant Management perspective is not already activated, do so by selecting it from Open Perspective
-> Other... in the Window menu.

2.2. How the pure::variants Connector for EMF Feature Mapping
Works

The pure::variants Connector for EMF Feature Mapping works for EMF-based files. Ecore and ecorediag resources
are supported out of the box. For other EMF-based resources an additional pure::variants Connector may be nec-
essary, such as the pure::variants Connector for Papyrus, Capella or IBM Rational Software Architect.

The pure::variants Connector for EMF Feature Mapping uses an EMF runtime master model to derive multiple
variants from it. Each of the variants is derived from the master runtime model by removing EMF elements not
relevant in the respective variant. Removal of elements is controlled by pure::variants conditions. Conditions can
be added to EMF elements by the master model author(s). The conditions are evaluated by pure::variants based on
a variant model which captures the variant-specific feature selection. Elements having conditions which evaluate
to 'false' are removed.

Apart from conditions, it is also possible to add a pure::variants calculation to an attribute of an EMF element.
Like conditions, calculations are evaluated based on a variant model. However, instead of removing the attribute,
its value is set to the evaluation result of the calculation.

3. Tasks

3.1. Creating Variability Information

Selecting a Mapping Model

To be able to add a condition or calculation to an EMF element, it is required to select a mapping model. The
mapping model is a pure::variants Family Model that stores which EMF elements are mapped to which condition
or calculation. To this end, open the Mappings view via Window->Show View and press Select Mapping Model

( ).
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Figure 1. Select Family Model used as Mapping Model

Creating a Condition on an EMF Element

There are multiple ways how to add an element to a condition: via the Mappings view context menu, via drag &
drop onto a condition, or via the context-menu of an EMF element.

Using Context Menu in Mappings View

At first a condition must be added in Mappings view using the New Condition context menu.

Figure 2. Create Condition by Context Menu

The menu opens the condition editor. The editor supports writing conditions with auto completion. To use the
auto completion press Ctrl+Space.

Figure 3. Condition Editor Showing the Auto Completion
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Pressing OK will store the new or changed condition into the loaded mapping model. To add an EMF element
to the newly created condition, select the element in the opened EMF model, right-click on the condition and
select Add ....

Alternatively, you can also drag & drop EMF elements on the condition.

Figure 4. Restricted EMF elements in Mapping view

Using Context Menu in EMF model

Another way to add a condition to one or more EMF elements, is to right-click on the selected element(s) in the
EMF model (e.g., in diagram or browser) and select pure::variants->Add to New Condition. This will open the
condition editor to create a new condition and then add the selected element(s) to it.

Figure 5. Adding EMF Element to New Condition

Alternatively, you can select pure::variants->Add to Existing Condition. This will open a dialog to select an
existing condition to which the selected element(s) will be added.

Creating a Calculation on an attribute of an EMF Element

EMF element attributes can be added to a calculation in similar ways as conditions: via the Mappings view context
menu, via drag & drop onto a calculation, or via the context-menu of an EMF element.
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Using Context Menu in Mappings View

First a calculation needs to be created in the Mappings view using the New Calculation context menu.

Figure 6. Create Calculation by Context Menu in Mappings View

The menu opens the calculation editor, which works in the same way as the condition editor.

Figure 7. Calculation Editor Showing the Auto Completion

Pressing OK will store the new or changed calculation into the loaded mapping model. To add the attribute of an
EMF element to the newly created calculation, select the element in the opened EMF model, right-click on the
calculation and select Add ....

Now, a dialog opens that allows to select the attribute on which the calculation should be applied. All attributes of
the current element are listed here. However, only attributes which are based on type String, Boolean, or a basic
number type, such as Integer, Float or Double are currently selectable.
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Figure 8. Attribute Selection Dialog

Similar to conditions, you can also drag & drop an EMF element onto the calculation. This will also open the
attribute selection dialog.

Figure 9. Restricted EMF elements in Mapping view

Using Context Menu in EMF model

Another way to add a calculation to an attribute of an EMF element, is to right-click on the selected element in
the EMF model (e.g., in diagram or browser) and select pure::variants->Add to New Calculation. This opens
the attribute selection dialog and after pressing OK, opens the calculation editor to create a new calculation and
then adds the selected attribute to it.

Alternatively, you can select pure::variants->Add to Existing Calculation. This also opens the attribute selection
dialog and after pressing OK opens a dialog to select an existing calculation to which the selected attribute will
be added.

3.2. Preview Variable Elements and Variant Results

Identify Variable Elements in EMF Models

To find out whether an element is mapped to a pure::variants condition or calculation, activate the Decoration

mode ( ) in the Mappings view. When decoration mode is enabled EMF elements are marked as follows in
EMF diagrams:
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Decoration Icon Shown when

an EMF element is mapped to a condition

an EMF element is indirectly mapped to a condition,
either because one of its parents is mapped, or due to
propagation (see the section called “Enable Propagation
Rules”)

an attribute of this EMF element is mapped to a calcu-
lation

mapped to both a calculation and a condition

mapped to both a calculation and an indirect condition

Figure 10. Decoration Mode in Diagram

When hovering over the decoration icon, more information is shown. For conditions, the effective pvSCL condi-
tion is shown. This means that all conditions that apply to this element are concatenated with operator AND. For
calculations, the pvSCL calculation that applies to this element is shown, and the attribute which is mapped to
the calculation.

To add this text information to the diagram, select Decoration Mode: Show Labels in Diagrams from the drop-
down menu of the Mappings view.

In EMF explorer, no icons are shown in decoration mode. However, the same text as in diagrams is added to
elements.

Color Elements

After activating the Colorize ( ) mode in the Mappings view all views and editors showing the EMF model are
updated to colorize elements which have a condition or calculation and this has set a color. To set a color, select
a condition or calculation and press the Change Color context menu in Mappings view.

Figure 11. Set Color of Condition

Use context menu to change color.

Choose the color.
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Figure 12. Preview Variant: Colorize Elements

Visualization in Ecore tree.

Visualization in Ecore diagram.

Preview a Variant

To enable the preview of variants a variant description model needs to be selected. To do this, open the Mappings

view and press the Assign Variant ( ) button.

This opens a file selection dialog. Please select the model and press OK.

Figure 13. Select Variant Description Model

The variant description model is loaded and evaluated. The Mappings view changes the images in front of con-
ditions. Before a variant is assigned the images are gray. After loading a variant the images are:

Result Icon Description

green if the condition evaluates to true

red if the condition evaluates to false

Furthermore, the evaluated value of the current variant is shown behind each calculation.
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Figure 14. Mappings View with Loaded Variant

The preview mode is also enabled. To start the visualization in the EMF model, activate the Variant ( ) mode.
All elements which are not part of a variant are grayed out. Alternatively, you can hide all elements that are not

in a variant, by selecting the other variant mode button ( ).

Figure 15. Preview Variant: Grayed-out Elements

Elements not in Variant are grayed-out in tree.

Elements not in Variant are grayed-out in diagram.

Highlight Condition of EMF Element

After selecting an EMF element, the condition that it is mapped to is shown in bold letters in the Mappings view.
Also all conditions that are propagated to this element are highlighted in bold letters (for details on propagation,
see the section called “Enable Propagation Rules”).
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Find Errors in Conditions or Calculations

Errors in conditions or calculations can be highlighted via button Show Errors ( ). For example, feature Air\
Pressure is misspelled in the first shown condition. Therefore it is underlined. Hover over the faulty condition
or calculation to see the error message.

Figure 16. Underlining Errors in Conditions or Calculations

3.3. Useful when working with the Mappings View

Navigate to an EMF Element

You can navigate to any EMF element shown in the Mappings view by using the Go To context menu. Wherever
the element is selectable, it will be shown and selected.

Figure 17. Navigate to EMF Element by Context Menu

Filter Conditions or Calculations

Conditions and calculations shown in the Mappings view can be filtered. To filter all elements shown in the
mapping view by text, type part of the their text in the marked text box (can be either part of the pvSCL expression,
or the name of an EMF element). Only the matching elements will be shown in the view.
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Figure 18. Underlining Errors in Conditions or Calculations

To show only conditions and hide all calculations, use button  at the end of the text box. For showing only

calculations, press .

Enable Propagation Rules

For some EMF tools a tool-specific Connector provides propagation rules. Basically a propagation rule ensures
that if Element A is removed during transformation, also Elements B, C, and D are removed. This influences also
visualizations and decorations.

If propagation rules are supported for the used EMF tool, you can enable or disable propagation rules by using

the Propagation settings button ( ) of the Mappings view. For more details on propagation, see the respective
EMF tool connector manual.

Select Calculations / Conditions

If an element is mapped to a condition or a calculation, it can be selected using the context menu in the EMF
model. Also, all conditions and caluations that are propagated to this element are selected. To select the conditions
or calculations, right-click on the selected element(s) in the EMF model (e.g., in diagram or browser) and select
pure::variants# Select Conditons or Select Calculations. This will select the respective conditions or the cal-
culations in the Mappings view.

Figure 19. Select Conditions on EMF element
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Alternatively, you can also right-click on the elements in the Capella Project Explorer to select the conditions
and calulations.

Show in Mappings View

The elements mapped to the conditions or calculations can be selected in the Mappings view. The elements are
selected under all the conditions and caluations that are propagated to this element. To select the element, right-
click on the selected element(s) in the EMF model (e.g., in diagram or browser) and select pure::variants# Show
in Mappings View.

Figure 20. Show in Mappings View on EMF element

Alternatively, you can also right-click on the elements in the Capella Project Explorer to select the elements in
the mapping view.

Figure 21. Selected element shown in the Mappings view.
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3.4. Changing Variability Information

Change a Condition for a Single Element

Changing the condition on a single element can be done by dragging the mapped element from one condition to
another. For this, a new condition can be created via the context menu (see the section called “Using Context Menu
in Mappings View”) or an existing condition can be used.

Figure 22. Changing Conditon by Drag and Drop

Drag Element from a Condition and to new Condition Drop Element on new Condition.

Change a Condition for all Elements

Select the condition in the Mappings view and double-click the condition or select the Change Condition context
menu. The condition editor with the current condition comes up. Edit the condition and press OK. The condition
will be updated on all elements.

Figure 23. Changing Conditon via Editor

Open Context Menu on Condition
and Select 'Change Condition ...'

After editing Condition all Elements
are located beneath new Condition.

Changing a Calculation

Calculations can be changed in the same way as conditions. You can either drag & drop the mapped attribute from
one calculation to another, or you can change the calculation itself via its Change Calculation context menu.

3.5. Creating EMF Model Variants

Variants of an EMF model will be created by opening the variant description model and creating a valid feature
configuration. A variant is then generated by performing a transformation of the variant.

To remove elements from the EMF file, please ensure that the transformation module configuration contains the
EMF Feature Mapping Module. Open the transformation configuration by expanding the Transform button
and select Open Transformation Config Dialog ....
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Figure 24. Open Transformation Configuration Dialog

Add a new module configuration for the transformation module.

Figure 25. Add new module configuration

Open one of the listed modules by double-clicking or add a new module by pressing Add. The Available Modules
are shown.
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Figure 26. Select EMF Feature Mapping Module

Ensure EMF Feature Mapping Module is checked and press Finish.

To start the transformation choose the configuration (standard name: Default) from the drop-down menu of the
transformation button.

Figure 27. Start Transformation

In the output folder (as defined in the transformation configuration, for standard projects the name is output) a
sub folder with name of the VDM is created. The generated variant of the EMF model can be found in that output
directory after the transformation finished.
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